Skip to main content

Requirements

KOTS#

KOTS VersionKubernetes Compatibility
1.471.18
1.481.21, 1.20 and 1.19

Releases are validated on the latest KOTS version available. The official compatibility is available here.

PostgreSQL#

GitGuardian currently supports PostgreSQL 11 and 12.

Required PostgreSQL Extensions#

GitGuardian Internal Monitoring requires these extensions:

ExtensionMinimal Version
pg_trgm1.4
plpgsql1.0

To install these extensions, you must run the following commands while connected as a superuser on the database instance. Depending on your installation, extensions may already be installed:

CREATE EXTENSION IF NOT EXISTS pg_trgm;CREATE EXTENSION IF NOT EXISTS plpgsql;

Redis#

GitGuardian currently supports Redis 5.